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Portfolio Website Design…

…The First Steps

Courtesy of adobe.com, 2009
Creating goals for your site… 
Deciding what your site goals are should be the first step you take when creating a Web site. Ask yourself, or your client, about what you hope to accomplish by having a Web site. Write down your goals so that you remember them as you go through the design process. Goals help you focus and target your Web site to your particular needs. 
A Web site that provides news about a specific subject should have a different look and navigation than a Web site that sells products. The complexity of your goals will affect the navigation, the media that you use (Macromedia Flash, Macromedia Director, and so on), and even the look and feel of your site.
Organizing the site structure…
Organizing your site carefully from the start can save you frustration and time later on. If you begin creating documents without thinking about where in your folder hierarchy they should go, you may end up with a huge, unwieldy folder full of files, or with related files scattered through a half-dozen similarly named folders. 

The usual way to set up a site is to create a folder on your local hard disk that contains all the files for your site (referred to as the local site), and to create and edit documents within that folder. You then copy those files to a Web server when you are ready to publish your site and allow the public to view it. This approach is better than creating and editing files on the live public Web site itself, because it allows you to test changes in the local site before making them publicly viewable. When you're finished, you can upload the local site files and update the entire public site at once. 
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Break down your site into categories and put related pages in the same folder. For example, your company press releases, contact information, and job postings might all go in one folder, but your online catalog pages might go in a different folder. Use subfolders where necessary. This type of organization will make your site easier to maintain and navigate. 

Decide where to put items such as images and sound files. For example, it's convenient to place all your images in one location, so that when you want to insert an image into a page, you know where to find it. Designers sometimes place all of the non-HTML items to be used on a site in a folder called Assets. This folder may contain other folders—for example, an Images folder, a Macromedia Shockwave folder, and a Sound folder. Or you might have a separate Assets folder for each group of related pages on your site, if there aren't many assets shared among such groups. 


Use the same structure for local and remote sites. Your local site and your remote Web site should have exactly the same structure. If you create a local site using Macromedia Dreamweaver and then upload everything to the remote site, Dreamweaver ensures that the local structure is precisely duplicated in the remote site.
Creating your design look… 

You can save a lot of time later if you plan your design and layout before you begin working in Dreamweaver. You can simply create a mock-up drawing on paper of how you want the site layout to look and then follow it as you build your site; or you can create a composite drawing of your site using software such as Macromedia FreeHand or Macromedia Fireworks. 

Maintaining consistency in your page layout and design helps to ensure a good user experience. The user should be able to click through the pages in your site without getting confused. If all the pages have a different look, or the navigation is in a different place on each page, it might frustrate the user. Make sure your site provides a consistent look for your user.
Designing the navigation scheme… 

As you design your site, think about the experience you want your visitors to have. Think about how a visitor to your site will be able to move from one area to another. Navigation should be consistent throughout your site. If you place a navigation bar across the top of your home page, try to keep it there for all the linked pages. Consider the following points: 
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	Visitors should know where they are in your site and how to return to your top-level page.
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	Search features and indexes make it easier for visitors to find information they are looking for.
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	Feedback features provide a way for visitors to contact the Webmaster (if appropriate) if something is wrong with the site, and to contact other relevant people associated with the company or the site.


Planning and gathering your assets… 

Once you know what your design and layout will look like, you can create and gather the assets that you will need. Assets can be items such as images, text, or media (Flash, Shockwave, and so on). Make sure you have all of these items gathered and ready to go before you begin developing your site. Otherwise, you'll have to continually stop development to find an image or to create a button. 

If you are using images and graphics from a clip-art site or someone else is creating them, make sure you collect them and put them in a folder on your site. If you are creating the assets yourself, make sure you create them all before you start development, including any images you need if you are using roll-overs. Then organize your assets so you can access them easily while creating your site in Dreamweaver. 

You can reuse page layouts and page elements in various documents by using templates and libraries in Dreamweaver. However, it is easier to create new pages with templates and libraries than it is to apply them to existing documents. 

Use templates if many of your pages will use the same layout. Plan and design a template for that layout, and then you can create new pages based on that template. If you decide to change the layout for all the pages, you can simply change the template. For more information on templates, see Chapter 16 of Using Dreamweaver 4, or Dreamweaver Help (Help > Using Dreamweaver). 
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Using Dreamweaver to Set Up a Local Site…
Courtesy of adobe.com, 2009
Using Dreamweaver to set up a new local site… 

After you create your local site's folder structure (see the Understanding sites article), you must provide Dreamweaver with information about the new site. It's best to set up your local site in Dreamweaver before you begin creating new pages. 

To create a new site: 

	1
	If you haven't already done so, create and name a folder on your disk (using Windows Explorer (Windows) or the Finder (Macintosh) that will be used as the local root folder. Each site must have a separate local root folder. 

	
	Note: Do not use the Dreamweaver application folder as the local root folder.

	2 
	Start Dreamweaver. Create a new document or open an existing one and save it in the new local root folder with the file name index.html. This file will be the home page of your site. (Check with your Internet service provider or your system administrator to be sure index.html is the correct file name to use. Some servers may require that the home page for the site be named index.htm or default.htm.) Don't worry about the contents of the file, you can change what's in the file later. 
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	3 
	Choose Site > New Site.

	
	In the Site Definition dialog box that appears, the Local Info category is selected. 
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	4 
	Enter the following options:
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	In the Site Name field, enter a name for the site. The site name appears in the Site window and on the Site > Open Site submenu. Use any name you like since it will not appear in the browser and is only for your reference. 
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	In the Local Root Folder field, specify the folder on your local disk that will contain all the files and folders for your site. Click the folder icon to browse to and select the folder. 
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	Select the Refresh Local File List Automatically option if it isn't already selected. This indicates that Dreamweaver should automatically refresh the local file list every time you copy files into your local site. [image: image11.png]IV Retresh Local File List Automatically
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	In the HTTP Address field, enter the URL that your remote Web site will use, so that Dreamweaver can verify links within your site. For example, the URL for the Macromedia Web site is http://www.macromedia.com. 
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	Select the Enable Cache option if it's not already selected. A site cache improves the speed of Dreamweaver for link and site management and lets you use the Assets panel. (For more information about the Assets panel, see the Dreamweaver documentation.) Unless you have a very large site, leave this option selected. 
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	5 
	Click OK.

	
	Dreamweaver creates a site cache.

	6 
	If the Site window doesn't appear, choose Site > Site Files.

	
	The Site window appears. The Site window provides two visual representations of your site (Site Map and Site Files) and can be used to open, add, and delete files. For more information about the site window and site management, see the Dreamweaver documentation. 
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You can now proceed to create your Web site. To modify the index.html file, double-click the file in the Site window. It opens in a Document window, where you can edit it. 

If you right-click (Windows) or Control-click (Macintosh) on your new index.html file, then select Set As Homepage, you can specify that index.html is the default home page. This lets you create site maps in Dreamweaver. 

When you're ready to publish the site on a remote server, you will need to add information about the remote site. 
Editing an existing local site…
You can use Dreamweaver to edit an existing site on your local disk, even if you didn't use Dreamweaver to create the original site. 
To edit an existing Web site: 
	1 
	Choose Site > New Site.

	
	In the Site Definition dialog box that appears, the Local Info category is selected. 
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	2 
	Enter the following options:
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	In the Site Name field, enter a name for the site. The site name appears in the Site window and on the Site > Open Site submenu. Use any name you like since it will not appear in the browser and is only for your reference. 
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	In the Local Root Folder field, specify the folder on your local disk that contains all the existing files and folders for your site. Click the folder icon to browse to and select the folder. 
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	Select the Refresh Local File List Automatically option if it isn't already selected, to indicate that Dreamweaver should automatically refresh the local file list every time you copy files into your local site. [image: image24.png]IV Retresh Local File List Automatically
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	In the HTTP Address field, enter the URL that your remote Web site will use, so that Dreamweaver can verify links within the site that use absolute URLs. For example, the URL for the Macromedia Web site is http://www.macromedia.com. 
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	Select the Enable Cache option if it's not already selected. A site cache improves the speed of Dreamweaver for link and site management and allows you to use the Assets panel. (For more information about the Assets panel, see the Dreamweaver documentation.) So unless you have a very large site, leave this option selected. 
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	3 
	Click OK.

	
	Dreamweaver creates a site cache.

	4 
	If the Site window doesn't appear, choose Site > Site Files.

	
	The Site window appears. The Site window provides two visual representations of your site (Site Map and Site Files) and can be used to open, add, and delete files. For more information about the site window and site management, see the Dreamweaver documentation. 
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You can now proceed to edit your Web site. To modify a file, double-click the file in the Site window. It opens in a Document window, where you can edit it. 

When you're ready to publish the site on a remote server, you will need to add information about the remote site. 
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Working with Images …

Courtesy of adobe.com, 2009
Inserting images… 

When you insert an image into a Dreamweaver document, Dreamweaver automatically generates a reference to the file in the HTML source code. Like other files that are part of a website, image files must also be saved somewhere within the local root folder defined for the site. If your image file is not in the current site, Dreamweaver asks whether you want to copy the file to the root folder. 

For more information about sites, see the article Understanding Sites. 

To insert an image: 

	1 
	Transfer the image file to a directory in your site before inserting the image, if it is not already in your current site.

	
	Tip: It is a good idea to store your images in a separate directory called "images."

	2 
	Place the insertion point where you want the image to appear in the Document window, and do one of the following:
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	Select Insert > Image.
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	Click the Insert Image button on the Common category of the Objects panel (Window > Objects). 
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	Press Control+Alt+I (Windows) or Command+Option+I (Macintosh).
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	Drag the Insert Image button from the Objects panel to the desired location in the Document window.
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	The Select Image Source dialog box opens.

	3 
	Navigate to the file you want to insert and select it, or type the path for the image file in the URL text box. 
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If you are working in an unsaved document, Dreamweaver generates a "file://" reference to the image file. When you save the document in the site, Dreamweaver converts the reference to a document- or site root-relative path. For more information, see "About document locations and paths" in Chapter 15 of Using Dreamweaver 4, or in Dreamweaver Help (Help > Using Dreamweaver).
Resizing images… 

You can visually resize images in the Dreamweaver Document window. Visual resizing helps you determine how an image affects the layout at different dimensions. 

To resize an image: 

	1 
	Select the image in the Document window.
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	Resize handles appear at the bottom and right sides and in the bottom right corner of the image. If resize handles don't appear, either click away from the image you want to resize and then reselect it, or click <img> in the tag selector to select the image. 
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	2 
	Resize the image by doing one of the following:
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	To adjust the width, drag the selection handle on the right side.
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	To adjust the height, drag the bottom selection handle.
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	To adjust the width and height at the same time, drag the corner selection handle.
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	To preserve the image's proportions (its width-to-height ratio) as you adjust its dimensions, Shift-drag the corner selection handle.
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	Select Window > Properties, and type values in the W and H text boxes in the Property inspector. 
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	Default and unlabeled values are pixels. You can also specify the following units: pc (picas), pt (points), in (inches), mm (millimeters), and cm (centimeters), and combinations thereof, such as 2in+5mm; Dreamweaver converts the values to pixels in the HTML source code.

	
	Note: When you resize an image manually in the Property inspector, the image's proportions are not automatically preserved.
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To return a resized image to its original dimensions: 
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	In the Property inspector (Window > Properties), delete the values in the W and H text boxes, or click Reset Size.


Image alignment… 

Use the Property inspector (Window > Properties) to set the alignment of a selected image. You can align an image in relation to text, another image, a plug-in, or other elements in the same paragraph or line by selecting alignment settings from the Align pop-up menu. You can also use the alignment buttons (left, right, and center) to set the horizontal alignment of an image. 
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Browser Default generally specifies a baseline alignment. (The default may differ depending on the site visitor's browser.) 

Baseline and Bottom align the baseline of the text (or other element) to the bottom of the selected image. 
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Top aligns an image to the top of the tallest item (image or text) in the current line. 

Middle aligns the text baseline with the middle of the selected image. 
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TextTop aligns the selected image with the top of the tallest character in the text line (which includes ascenders, as in the letter b). 

Absolute Middle aligns to the absolute middle of the current line. 

Absolute Bottom aligns to the absolute bottom (which includes descenders, as in the letter g) with the bottom of the selected image. 

Left places the selected image on the left margin, wrapping text around it to the right. 
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Right places the selected image on the right margin, wrapping text around it to the left.
Adding space around images… 

If you want to add space around an image (for example, if you want a space between an image and the text that appears next to the image), use the V Space and H Space text boxes in the Property inspector. 

To add space around an image: 

	1 
	Select the image in the Document window.

	2 
	Select Window > Properties to open the Property inspector, if it is not already open.

	3 
	Click the expander arrow to expand the Property inspector to its full dimensions, if necessary. 
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	4 
	In the Property inspector, do any of the following:
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	Type a value in the V Space text box to add space in pixels along both the top and bottom of an image.
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	Type a value in the H Space text box to add space in pixels along both the left and right of an image.


Linking images… 

You can make an image a link that points to another file on your site (or to another website). 

To link an image to another file on your site: 

	1 
	Select the image in the Document window.

	2 
	Select Window > Properties to open the Property inspector, if it is not already open, and do one of the following:
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	Drag the Point to File icon (next to the Link text box) to a file in the Site window.
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	Click the folder icon (next to the Link text box) to browse to a document on your site.
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	Type the URL path in the Link text box.
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To link an image to another website: 
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	Type the full URL (for example, http://www.macromedia.com) in the Link text box in the Property inspector (Window > Properties).


Setting image borders… 

You can set the width of the border, in pixels, around an image. 

If an image has a border and a link, the border will be the color set for the link color in the Page Properties dialog box (Modify > Page Properties). 

If an image has a border but does not have a link, the border will be the same color as the paragraph text in which the image is inserted. 

Note: In some browsers the default color for an image border is black unless you link the image. Additionally, some browsers will display a border, even if you have not designated one. To ensure no border for a linked image appears, set the border for that image to 0. 

To set border width around an image: 

	1 
	Select the image in the Document window.

	2 
	Select Window > Properties to open the Property inspector, if it is not already open.

	3 
	Type a pixel width in the Border text box, or type 0 for no border. 
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Setting alternative text for accessibility… 

You can specify alternative text that will appear in place of the image for text-only browsers or for browsers that have been set to download images manually. For visually impaired users who use speech synthesizers with text-only browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is over the image. 

To set alternative text for an image: 

	1 
	Select the image in the Document window.

	2 
	Select Window > Properties to open the Property inspector, if it is not already open.

	3 
	Type descriptive alternative text in the Alt text box. 
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Getting Familiar with the Interface …

Courtesy of adobe.com, 2009
Checking the instruments: essential palettes and inspectors… 

Dreamweaver has three floating interface elements that you're likely to leave open most of the time: the Launcher, the Object palette, and the Property inspector. 

The Launcher…
Use the Launcher to open and close Dreamweaver's palettes and inspectors with a single click. The icons from the Launcher are repeated (without labels) at the bottom of the Document window in the Mini-Launcher. Click an icon in either place and notice that the icon is highlighted in both the Launcher and the Mini-Launcher. Once you learn the Launcher icons, you can close this window and rely on the Mini-Launcher. This will free up screen space. 
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The Object palette…
The Object palette duplicates the functionality of the Insert menu, letting you insert page elements with a click of the mouse. Click any object's icon or drag the icon into the Document window to create the specified object. 
If you don't recognize the icons in the palette, let the pointer rest on each one to see a tooltip. You can also set a preference to display text labels along with the Object palette icons. (Choose Edit > Preferences, and then choose General from the category list. Change the Object Palette option to Icons and Text.) 

The elements in the palette are grouped into six panels: Characters, Common, Forms, Frames, Head, and Invisibles. Use the pop-up menu at the top of the Object palette to switch between panels. 
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When you click an element in the Object palette, a dialog box may appear to request the source file, dimensions, codebase, or other attributes for the element. If you would rather never be presented with this dialog box, choose Edit > Preferences, and then choose General from the category list; then deselect the Show Dialog when Inserting Objects option. To instead bypass the dialog box on a case-by-case basis, hold down the Control (Windows) or Option (Macintosh) key while you click an object. Dreamweaver inserts a placeholder for the object or inserts the object using default values. 

The Property inspector
The Property inspector displays the properties of the currently selected HTML element. These properties correspond to the attributes of the HTML tag or tags associated with the element. For example, when an image is selected, the Property inspector displays the width ( W ), height ( H ), source ( Src ), alternate text ( Alt ), and other information about the image. When text is selected, the Property inspector displays the paragraph format, font, size, and other information about the text. 
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To see how the Property inspector changes for each element, try inserting several HTML elements by Control-clicking (Windows) or Option-clicking (Macintosh) various buttons in the Object palette. Select each element in the Document window, and then fill in different values for the properties and watch what happens. 
Try this exercise to see what the Property inspector does when you adjust the width and height of an image: 

	1
	Click the Insert Image button on the Object palette.

	2
	In the dialog box that appears, browse to a GIF or JPEG file.

	3
	Click Select (Windows) or Choose (Macintosh). If a dialog box appears with a message about relative paths, click OK.

	4
	In the Property inspector, type in new values for width ( W ) and height ( H ).

	
	Notice that the numbers you entered have become bold. This indicates that the width and height you entered are not the actual width and height of the image. Images look better, and generally take much less time to download, if you resize them in an image editor (such as Macromedia Fireworks), rather than specifying a width and height in the HTML file for the browser to use in resizing the image. However, you might want to temporarily resize the image in the Property inspector to see how a different image size would affect your layout. To return the values to their original settings, click the W and H text labels.
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One attribute in the text Property inspector is worth mentioning: the Size pop-up menu lists values like 1, 2, 3, +1, +2, +3, -1, -2, and -3 instead of point sizes. This is because font sizing in HTML uses a relative scale of 1 to 7, where 3 is the default size. Before Netscape Navigator 4.0 and Microsoft Internet Explorer 3.0 were released, it was impossible to set the point size of fonts in a browser. Now both Navigator and Internet Explorer offer support for Cascading Style Sheets, which allow specific font sizes (as well as many other precise settings). To set attributes using CSS styles in Dreamweaver, click the CSS Styles button in the Launcher
Reviewing the manual controls: the Document window and the HTML Source inspector… 

You'll quickly learn while working in Dreamweaver that you have two very different ways to view the pages you're creating: the Document window displays the page as it looks in a browser, and the HTML Source inspector shows the underlying HTML code. You can work in one or the other, or view both at the same time.
	The Document window… 

The Document window displays the current document approximately as it will appear in a Web browser. To start creating a Web page in the Document window, start typing or inserting objects. 

The following picture shows some of the items at the bottom of the Document window that make it easy to accomplish tasks quickly in Dreamweaver.
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	The HTML Source inspector…


Originally designed as a way to give advanced coders immediate access to the HTML (and to get them to trust that Dreamweaver would produce clean and accurate code), the HTML Source inspector can be useful to beginning Web developers who want to learn more about HTML. 

The HTML Source inspector generates code in real time as you add, move, and change the properties of elements in the Document window. This allows you to learn the tags, attributes, and legal attribute values for the elements in a Web page. 
To see how this works, try modifying as many attributes of an image as possible, keeping the HTML Source inspector open and reviewing the new code as you work. 

If you prefer, you can work primarily in the Document window. When you get the effect you want, you can open the HTML Source inspector to see the code that produces that effect. To find the exact code for an element, select the element in the Document window. The corresponding code is highlighted in the HTML Source inspector.


	[image: image72.png]



	

	
	[image: image73.png]'Welcome to the Workspace (Test-site/Workspace.htm”) - Dreamweaver B[ E
Fle EGt View lseil Modiy Tet Commands Sie Window Hep

The displays the current document
approximately as it will appear in a \Web browser.

Workspace-htn - HTML Source =
<O HTML Souoe |

(ComiEser, 7 viap [ Line oo ]
<html> a -
<head>

<titlesWelcome to the Vorkspase</title>
<meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1">

</head>

<Body bgcolor="gFFFFFFT>
<font size=ran face="irial, Helvetica, sans-serif’>The

displays the current document approximately as it will

P fon 0 (25 o -
g | ,

<bodp <font> <b> 500%371 - [1K/Tsec o3 L) Wl © & > <> 4







	[image: image74.png]



	

	
	This approach is similar to what many people did to learn HTML back in the early days (before 1995): they would write some HTML code, view it in a browser, adjust the attributes and surrounding tags, and so on until they got the effect they wanted. Unfortunately, this method was susceptible to typos and other errors (often introduced by having to guess at valid attribute values). The difference with Dreamweaver is that you don't have to know tag and attribute names and values—you can experiment with the settings and be confident that Dreamweaver is generating valid code.


Final preparations for takeoff: page properties… 

Many hand-coders, when starting a new HTML page, begin by typing the following code: 

<HTML>

<HEAD>

<TITLE>my page</TITLE>

</HEAD>

<BODY BGCOLOR="#FFFFFF" TEXT="#000000"LINK="#FF3300" VLINK="#333399" ALINK="#000000">

While typing this essential information, a coder might think about what had to go on the rest of the page. 
If you are coming to Dreamweaver from hand-coding, you might want to substitute this new ritual for every page you create. 

To set the page properties: 

	1
	Choose Modify > Page Properties.

	2
	In the Page Properties dialog box, type in a title for the page.

	3
	Select colors for the page background, text, links, visited links, and active links.
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	4
	Click OK.
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What you've just done is set up your environment: you've prepared yourself—and the page—for the creative part of your work. You've also made the lives of visitors who would bookmark your page a little easier by not giving them yet another Untitled page. 

Good to go… 

Now that you've seen an overview of the Dreamweaver workspace, you're ready to start creating pages. If you run into trouble in the Document window—for example, if you see extra space that you don't want—don't panic. Just use the Launcher to pop open the HTML Source inspector and see what you've got. (In the case of extra space, chances are that you'll see an extra <p>&nbsp;</p> in your code. Highlight this snippet, delete it, and click back in the Document window to continue.) 

After a while, you'll become so comfortable flipping back and forth between the graphical view and the HTML Source inspector that you won't even notice you're doing it. And in the process, you'll become an HTML expert. Good luck!

Streamwood High School Photography, Ms. Cress

Frame Fundamentals…

 Courtesy of adobe.com, 2009
Creating frames and framesets… 

The best way to understand how frames work—and specifically how to work with them in Dreamweaver—is to create some. You'll start by creating a frameset structure that's common on the Web: one that includes a navigation area on the left, a title or ad banner area along the top, and a main content area on the right. When you're finished, your frameset will look like this: 
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To create the frameset: 

	1
	Create a new document (File > New). 

	2
	Set up your workspace as follows:
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	Make frame borders visible by choosing View > Frame Borders.
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	Close all of the floating palettes and inspectors in Dreamweaver except the Object palette (Window > Objects), the Property inspector (Window > Properties), the Frame inspector (Window > Frames), and the HTML Source inspector (Window > HTML Source). 
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	Arrange the workspace so you can see the Document window, Object palette, Property inspector, HTML Source inspector, and Frame inspector all at once.
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	3
	To create the main frameset, which consists of two columns, in the Object palette in the Frames panel, select the Insert Left Frame icon at the top left of the Frames panel. 
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	You now have two frames and three documents: the main frameset file plus a new, untitled document in each of the two frames. 

	
	A border appears around the entire document in the Frame inspector when a frameset is selected. 

	
	Notice that the Frame inspector shows two areas, identified as leftFrame and mainFrame. 
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	Take a look at the frameset Property inspector.
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	4
	In the HTML Source inspector, notice that the frameset HTML consists of the opening and closing FRAMESET tags and any FRAME tags in between.
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	In the HTML Source inspector, change the page title from Untitled Document to Welcome to Homebody Realty . Type the page title between the TITLE tags located near the beginning of the source code in the HTML Source inspector.

	
	Click in the Dreamweaver document to see the page title update.

	5
	Click in the left area of the Frame inspector, and then look at the frame Property inspector. Also notice that the first FRAME tag in the HTML Source inspector is highlighted.
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	If you click in the right area of the Frame inspector, the second FRAME tag is highlighted. 

	6
	Select the frameset, then choose File > Save Frameset. In the dialog box that appears, create a new folder called frames inside your local root folder and save the file in the new folder as index.html. 

	
	This file contains information about the size and position of each of the frames. 


Creating a nested frameset… 

Next you'll create a nested frameset—a frameset within the main frameset—that consists of two rows. 

To create a nested frameset: 

	1
	Click inside the right frame, then do one of the following:
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	In the Object palette in the Frames panel, select the Insert Top Frame icon. 
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	Choose Modify > Frameset > Split Frame Down.

	
	The right frame splits into two separate frames, creating a second frameset within the main frameset. 
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	Notice that the nested frameset also contains a border outline. 

	
	There are now three frames, two framesets, and four documents in your window.

	2
	Save the frameset (File > Save Frameset).


Setting frame sizes (relative and exact size)… 

Before you begin filling your frames with content, it's a good idea to add some more details about the frames to your frameset file. The sizes of the frames aren't quite what you want yet; to resize them, you'll either need to drag the frame borders around or enter values into the Property inspector. The former method is great for roughing out frame positions, but the latter method offers the opportunity to set a precise, fixed size for a frame or to designate the size as relative to the browser window. 

You set frame properties by selecting the frame and entering values in the frame Property inspector. You set frame sizes, however, by selecting the frameset and entering values into the frameset Property inspector. This is because size information is stored in the FRAMESET tag as you can see in the HTML Source inspector. 

To set the size of each of the frames: 

	1
	Select the main frameset by clicking the outermost frame border in either the Frame inspector or the Document window.

	2
	If you don't see the frame sizing controls, click the expander arrow at the bottom right corner of the Property inspector.

	3
	In the Property inspector, in the RowCol Selection box click the left frame of this frameset image to set the frame's options. 

	4
	In the Value field type 150, and then in the Units pop-up menu select Pixels to set the column's width.


	[image: image97.png]



	[image: image98.png]Frameset

3

'
2

Borders [P =] Borter Color

Borderwidth [0

v s

Cotumn 150 ez =

Rovcal
Setecion

[CXS)







	5
	In the Property inspector, in the RowCol Selection box click the right frame, and then select Relative from the Units pop-up menu.

	
	Dreamweaver automatically fills in a value based on the current size of the Document window. 

	6
	In the Frame inspector, select the nested frameset (the thick border around the two right frames).

	7
	In the Property inspector, in the RowCol Selection box select the top frame. Enter 45 for the Value and select Pixels from the Units pop-up menu.

	8
	In the RowCol Selection box select the bottom frame. Select Relative from the Units pop-up menu.

	
	In the HTML Source inspector, you'll see this number with an asterisk (*) next to it. The asterisk indicates that the value should change according to the size of the Document window or browser window.


Setting frame borders… 

You may have noticed that the completed Homebody Realty frameset did not have borders. Borders are not necessary because the background color in each frame makes the boundaries between frames clear. 

Border properties, like frame sizes, are set in the frameset Property inspector. Border settings for the main frameset also affect all nested framesets. 

To remove frame borders: 

	1
	In the Frame inspector, select the outermost frameset.

	2
	In the Property inspector, Select No from the Borders pop-up menu.

	
	The three-dimensional borders disappear, leaving only thick gray lines.

	3
	Still in the Property inspector, set Border Width to 0.

	
	The thick gray lines shrink to about 2 pixels wide. These lines represent the frame boundaries and are visible only when View > Frame Borders is on. They are similar to the dashed table cell boundaries that are still visible when a table border is set to 0.


Setting frame properties… 

Next you will specify properties and a name for each frame in the frameset. Since each frame will play a different role in the frameset, each will have different properties. 
To set the properties of the left frame: 

	1
	In the Document window, select the left frame by pressing Alt (Windows) or Shift+Option (Macintosh) and clicking inside the frame.

	
	You can also select the frame by clicking it in the Frame inspector.

	2
	In the Property inspector, change the text in the FrameName field to hb_navigation .

	
	It's good practice to give each frame in your site a unique name. This prevents confusion, and it can even help you determine if a frameset is loaded. (Using JavaScript, you could check for the existence of parent.hb_navigation , for example, to see if the Homebody Realty frameset was in the browser window. This is a useful technique for preventing framesets from opening within other framesets.) Also, avoid spaces and hyphens in frame names. While they will not break straight HTML, spaces and hyphens are not allowed in JavaScript objects or properties.

	3
	Set Margin Width to 5 and Margin Height to 10.

	
	This moves the contents of the frame 5 pixels away from the left and right frame boundaries, and 10 pixels away from the top and bottom frame boundaries.

	4
	From the Scroll pop-up menu, select Auto.
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	This makes scroll bars appear if the content exceeds the available screen space. Generally, vertical scroll bars are fine in navigation and main content frames, but you should design your content so that horizontal scroll bars never appear. (It's very difficult for users to read text if they have to scroll in two directions.) To avoid horizontal scroll bars, make sure that the content will wrap naturally or that it will fit in the frame without wrapping even when vertical scroll bars appear. (This could mean that an image in a 150-pixel-wide frame might have to be 120 pixels or narrower.)
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To set the properties of the top right frame: 

	1
	In the Document window, press Alt (Windows) or Shift+Option (Macintosh) and click in the top right frame.

	2
	In the Property inspector, type this name for the frame: hb_header.

	3
	Set Margin Height to 10.

	4
	From the Scroll pop-up menu, select No.

	
	Since this frame will contain only the name of the site, scroll bars should never appear.
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To set the properties of the bottom right frame: 

	1
	In the Document window, press Alt (Windows) or Shift+Option (Macintosh) and click in the bottom right frame.

	2
	In the Property inspector, type this name for the frame: hb_main.

	3
	Set Margin Width to 20 and Margin Height to 10.

	4
	From the Scroll pop-up menu, select Auto.

	
	The Frame inspector now displays the names of the frames. 
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	5
	Save the frameset (File > Save Frameset). 


Opening an existing document inside a frame… 

The easiest way to populate a frame is to open an existing document inside it. To do this with the Homebody Realty site, you'll save a copy of the document that goes in the hb_header frame. 
To save the header file to your hard drive: 

	1
	Click this link to open the file in a new browser window.

	2
	Choose File > Save As from the browser menu.

	3
	Save the document as 00_header.html in the frames folder you created earlier. (Macintosh users: Be sure to select Source from the pop-up menu at the bottom of the Save As dialog box.)

	
	You might want to save all the documents that appear in your default frameset with the prefix 00_ so that they appear together at the top of the file list in the Site window (as well as in Telnet sessions and FTP programs). This way, whenever you want to edit just the navigation, you don't have to scan your file list trying to remember what you named the file in any particular frame.
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To open the header file in the hb_header frame: 

	1
	In the Document window, click inside the hb_header frame.

	2
	Choose File > Open in Frame.

	3
	In the dialog box that appears, find 00_header.html and open it.

	4
	Before going any further, save all the documents in the frameset by choosing File > Save All. 

	
	Dreamweaver will prompt you to save any untitled documents one at a time, indicating that the document that is being saved with a dashed outline in the Document window. 

	
	Save the file in the hb_main frame as 00_main.html and the file in the hb_navigation frame as 00_navigation.html.


Creating a document inside a frame… 

Next, you will create the content for the other frames. 
To create the content for 00_navigation.html: 

	1
	In the Document window, click inside the hb_navigation frame.

	2
	Right-click (Windows) or Control-click (Macintosh) and choose Page Properties from the context menu.

	3
	In the Background Color box, type #99CCFF.

	4
	Set Text Color to #000000, Link Color to #000099, and Visited Links to #000066.

	5
	Type a title for the page (such as Homebody Main Navigation) and click OK.

	6
	Type the following items into the frame, pressing Enter (Windows) or Return (Macintosh) after each item: property search, agent search, offices, mortgage services, relocation services.

	7
	Choose File > Save.
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To create the content for 00_main.html 

	1
	In the Document window, click inside the hb_main frame.

	2
	Right-click (Windows) or Control-click (Macintosh) and choose Page Properties from the context menu.

	3
	In the Background Color box, type #FFFFFF.

	4
	Set Text Color to #000000, Link Color to #000099, and Visited Links to #000066.

	5
	Type a title for the page (such as Homebody Main) and click OK.

	6
	Save the following image to the frames folder by right-clicking on it (Windows) or clicking it and holding down the mouse button (Macintosh) and choosing Save Image As from the context menu: 
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	7
	Back in the hb_main frame in Dreamweaver, choose Insert > Image. Browse to house.jpg and click OK.

	8
	With the image selected, choose Text > Alignment > Center.

	9
	Choose File > Save.


Targeting a frame… 

Most likely, you'll want visitors to the Homebody Realty site to click the items in the hb_navigation frame to open documents in the hb_main frame. To make this happen, you must make these items links and assign them targets. 

For now, create a dummy file for each item in the list so that you'll have something to link to. 

To create dummy files: 

	1
	Choose File > New to open a new document.

	2
	In the Document window, type Property Search.

	3
	Choose File > Save and save the file as propsearch.html in the frames folder.

	4
	In the Document window change the word Property to Agent.

	5
	Choose File > Save As, and save the file as agentsearch.html in the frames folder.

	6
	Repeat steps 4 and 5 for the remaining navigation items, changing the words in the file to Offices, Mortgage Services, and Relocation Services. Save the files as offices.html, mortgage.html, and relocation.html, respectively.
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To create a targeted link: 

	1
	Highlight an item in the navigation list (for example, property search).

	2
	In the Property inspector, click the folder icon next to the Link box then browse to and select the file associated with this item (for example, propsearch.html).

	3
	Choose hb_main from the Target pop-up menu.
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	The hb_main frame will be available in the Target list only when a frameset file with a frame called hb_main is open in Dreamweaver. If you open 00_navigation.html directly, only the default targets ( _blank , _parent , _self , and _top ) will appear in the Target list. You can still target hb_main by typing hb_main in the Target box.

	4
	Repeat steps 1 through 4 for each of the remaining navigation items.

	5
	Choose File > Save All.

	6
	Press F12 to preview the frameset file in your primary browser.


Changing two frames with one click… 

Next, you'll learn an advanced technique: targeting two frames with one click. (Once you start working with frames, it won't be long before you'll need to do this.) 

Before starting the procedure, you'll need to create one more dummy file to link to. 

To create a dummy file: 

	1
	Choose File > Open, and browse to 00_header.html.

	2
	Change the words Homebody Realty to Homebody Financial Services.

	3
	Right-click (Windows) or Control-click (Macintosh) and choose Page Properties from the context menu.

	4
	Change the Background Color from #000099 to #009900 and click OK.

	5
	Choose File > Save As, and save the file as hb_financial.html in the frames folder.
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The easiest way to target two frames with one click is to use the Dreamweaver Go To URL behavior action. 

To apply the Go To URL behavior action to the navigation items: 

	1
	Click in the middle of an item in the hb_navigation frame.

	2
	Choose Window > Behaviors to open the Behavior inspector. 
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	3
	Click the Plus (+) button and choose Go To URL from the Actions pop-up menu.

	4
	In the dialog box that appears, select hb_header from the Open In list.
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	5
	If the navigation item is Property Search, Agent Search, Offices, or Relocation Services, browse to and select 00_header.html. If the item is Mortgage Services, browse to and select hb_financial.html.

	
	Why should you specify 00_header.html for four out of the five links when it's already in the hb_header frame? Because you want to have the hb_header frame return to 00_header.html if a visitor clicks Mortgage Services and then one of the other items.

	6
	Select hb_main from the Open In list. Browse to and select the file associated with the item (for example, propsearch.html goes with Property Search, offices.html goes with Offices, and so on).

	7
	Click OK.

	8
	Repeat steps 1 through 8 for the remaining navigation items.

	9
	Press F12 to preview the frameset file in your primary browser.


Streamwood High School Photography, Ms. Cress

Using Cascading Style Sheets…

 Courtesy of adobe.com, 2009
What are styles? 

There are three general approaches to formatting text in Dreamweaver: 
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	Apply individual HTML tags (such as B or FONT SIZE=2 ) to the text.
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	Create an HTML Style—a set of HTML text-formatting tags, stored as a unit by Dreamweaver—and apply it to the text.
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	Create a Cascading Style Sheet to apply to one or more documents.


The term style, as used in Dreamweaver, can refer to either an HTML Style or a style definition in a Cascading Style Sheet. In this article, the term exclusively refers to a CSS style. 

Style definitions can include information about what font the text should appear in, how much space should surround the text, what color and size it should be, and other attributes. A style can be applied to any range of text; which style applies to a given range of text is determined by the tag or combination of tags that contain the text, or by CLASS or ID attributes in those tags. A style can, for example, redefine the appearance of all text tagged H1 , or can apply to all text contained in tags with a particular ID attribute. 

CSS styles became available with Microsoft Internet Explorer 3.0 and Netscape Navigator 4.0. While some style attributes are still not implemented in either Internet Explorer or Navigator, and some other styles behave differently in each browser, the most common and useful styles work well in recent versions of both browsers. For best results, stick to style attributes that are implemented the same way in both Netscape Navigator and Internet Explorer. That approach also has another advantage: a page without advanced CSS formatting generally looks fine (even if not exactly the way you want it to look) in browsers that don't support CSS (including older versions of Navigator and Internet Explorer), so users of such browsers don't notice that they're missing anything.
	Why use styles to change the appearance of text? 

The traditional way to make an H1 heading appear as green Helvetica text was to wrap it in FONT tags. (In Dreamweaver you can do this by selecting some text and choosing a font or series of fonts and a color in the Property inspector; to apply the same FONT -tag formatting to multiple pieces of text, use HTML Styles.) For example: 

<H1><FONT FACE="Helvetica" COLOR="green">a level-one heading</FONT></H1>

Using CSS you can, if you wish, give the same information using a STYLE attribute:
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	<H1 STYLE="font-family: Helvetica; color: green">a level-one heading</H1>
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	But putting style information inside a tag defeats the whole purpose of styles, which is to separate the formatting from the content. If you want to make every H1 header Helvetica and green, wrapping the H1 in FONT tags is just as efficient—or rather, inefficient—as including a STYLE attribute in each H1 . 

This is where the sheets part of Cascading Style Sheets comes in. A style sheet is a list of style definitions that goes in the head of your HTML document. If you put the style information for H1 in the style sheet, all H1 s in your document will automatically be Helvetica and green. 

<STYLE TYPE="text/css">

H1{ font-family: Helvetica;

color: green }

</STYLE>

This not only saves you a lot of typing when you create a document, but it also saves you a lot of retyping later if you decide the font should really be Arial and the color red, because you'll only need to make the change in one place. 

Of course, with Dreamweaver you don't need to type any of that into your document; instead you use the CSS Style palette to create and modify styles.


Using linked style sheets… 

Having separated style from substance by moving the style information out of the body and into the head of your document, you can now take this idea one step further and define a style sheet for your entire site instead of each document individually. 

To do this, store all of your style definitions in an ASCII file with a .css file extension, and then link documents to this style sheet with the LINK REL tag. 

<LINK REL="stylesheet" HREF="site_styles.css">

(Again, using Dreamweaver you don't have to type that into your file; the CSS Style palette keeps track of linked style sheets for you.) 

If you have many styles defined in site_styles.css and want to use all but one of them in a particular document, you can override that one style in the document itself. This is where the cascading part of Cascading Style Sheets comes in. 
For example, if site_styles.css contains the Helvetica/green definition for H1 s, and for the current document you want all H1 s to be Helvetica and red, you could put the following code in the head of your document: 

<LINK REL="stylesheet" HREF="site_styles.css">

<style type="text/css">

H1{color: red }

</style>

All the H1 s in your document will use the font information from the linked stylesheet, but they will be red instead of green because the local style definition of the H1 tag overrides the corresponding parts (the color, in this case) of the style definition in the linked style sheet
Creating a tag style… 

Don't worry, you won't have to remember all this strange new syntax. Dreamweaver makes defining styles, applying styles, and setting up style sheets easy. 

To make the demonstration a little simpler, open this basic HTML file in your browser and choose File > Save As. In Windows, make sure that the Save as type pop-up menu reads Web Page, complete or HTML Files. On the Macintosh, make sure that the Format pop-up menu reads Source or HTML Source, not Text. Save the file as basic.html in the local root folder of one of the sites you've defined in Dreamweaver (see Site Management in the Dreamweaver Help pages or the Using Dreamweaver manual), and then open basic.html in Dreamweaver. 

To define a style for an HTML tag: 

	1
	Choose Window > CSS Styles to open the CSS Style palette.

	2
	In the CSS Style palette, click the New Style icon.

	
	A New Style dialog box appears.

	3
	Select the Redefine HTML Tag option, and choose h2 from the text field's pop-up menu. Click OK.

	
	A Style definition for h2 dialog box appears.

	4
	Make sure Type is selected in the Category list on the left.

	5
	From the Font pop-up menu, choose Arial, Helvetica, sans-serif.

	6
	From the Weight pop-up menu, choose 700.

	
	Font weights can be defined using words like bold, bolder, or lighter; they can also be defined on a scale of 100 to 900. The normal weight is 400; 700 is bold; 900 is extra bold.

	7
	From the Size pop-up menus, choose 16 and points.

	
	Unlike HTML, CSS definitions are not limited to a relative font size scale. You can define a style with any type size you like, using any of several measures—points, mm, pixels, and so on. 

	
	Note: Because the screen resolution on many PC monitors is different from that of Macintosh monitors, fonts may appear significantly larger on Windows computers. If you're creating pages in Windows, you may want to use slightly larger-than-normal fonts to improve readability on the Macintosh; if you creating pages on the Macintosh, you may want to use slightly smaller fonts so they won't look huge on Windows. Alternatively, you can specify different style sheets for Macintosh and Windows.

	8
	Point to the color box and drag to select your favorite shade of green, or enter #006600 in the Color text field.

	9
	Click Apply.

	
	The results are now visible in the Document window. If you like what you see, click OK. If you prefer a different color or font size, make adjustments and click Apply again.
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Repeat this procedure to define styles for TD and A . Make the font for TD Courier New, Courier, mono. Don't define any other attributes. For A , set only the Decoration: Select the none option to prevent links from being underlined.
Creating a selector style… 

You may have noticed that the items in the right column of the table were enclosed in CODE tags. (Click in any of the cells in that column and look at the tag selector at the bottom of the Document window. You'll see <code> among the tags listed.) Enclosing text in CODE tags causes the text to appear in a monospace font, usually Courier New in Windows and Courier on the Macintosh. 
But when you defined the style for TD , you set all of the text inside table cells to appear in Courier New (or the default monospace font if Courier New or Courier is not available). This makes CODE text indistinguishable from regular table cell text. To solve this problem, you could define a style for CODE to make it a different color or font; but what if you want the occurrences of CODE in paragraphs to continue to appear in their standard monospace font with no color? 

One solution is to create a style specifically for CODE when it appears inside a TD . A CSS selector style can apply to a particular tag when it occurs inside another particular tag. 

To create a selector style: 

	1
	If the Edit Style Sheet dialog box is not showing, click the Open Style Sheet button in the CSS Style palette to open it.

	2
	Click New, select the Use CSS Selector option, and type TD CODE in the text field. Make sure that there is a space between TD and CODE . Click OK.

	
	A Style definition for TD CODE dialog box appears

	3
	In the Color option, point to the color box and drag to select a dark red, or enter #990000 in the Color text field.

	4
	Click Apply.

	
	The results are now visible in the Document window. If you like what you see, click OK. If you prefer a different color, make adjustments and click Apply again.
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Notice that all of the CODE text in the table is now dark red, but the CODE text in the first paragraph (the terms H2 , TD , and A ) is not.
Creating a class style… 

Now that you've defined styles for a few individual HTML tags and one combination of tags, examine the footer in the basic.html file. Is there a specific tag or combination of tags that describes it? It contains a link, and the footer itself is a paragraph, but both the P tag and the A tag could be used elsewhere in the document. There are three other P -tagged paragraphs in basic.html that probably shouldn't have the same appearance as the footer, and not all of the footer is a link. Therefore, neither a tag style nor a selector style will work for the footer. 

Instead, mark this particular paragraph as one that should be styled in a certain way. CSS allows for this type of marking with class styles. You can distinguish a class style from other CSS styles by its name: a class style begins with a dot (for example, .footer , .green , or .runInHead ). When you create a class style, you don't need to put a dot at the beginning of the name, though; Dreamweaver does that for you automatically. 

To create a class style: 

	1
	If the Edit Style Sheet dialog box is not showing, click the Open Style Sheet button in the CSS Style palette to open it.

	2
	Click New, select the Make Custom Style (class) option, and type footer in the text field. Click OK.

	3
	From the Font pop-up menu, select Arial, Helvetica, sans-serif.

	4
	From the Size pop-up menus, select 9 and points.

	5
	Click OK.

	
	Clicking Apply has no visible result in the Document window because you have only defined the class style thus far. You haven't yet designated which tags or ranges of text the style will apply to.

	6
	In the Edit Style Sheet dialog box, click Done.
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To apply a class style: 

	1
	Click anywhere in the footer text (for example, between the words "Visit" and "the").

	2
	In the tag selector at the bottom of the Document window, click the <p> tag.

	
	The entire footer is selected.

	3
	In the CSS Style palette, click footer . (If the Auto Apply checkbox isn't selected, click the Apply button.) 

[image: image122.png]® csssyes | ol

apphTo: [<p> acten






	
	The footer text appears in 9-point Arial. (It appears in Helvetica if Arial is not available on your system, or the default sans-serif font if neither Helvetica nor Arial is available.)
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In the above procedure you selected an entire paragraph and applied a class style to it. If you open the HTML Source inspector (Window > HTML Source), you can see that Dreamweaver added a class="footer" attribute to the footer's P tag. You can also apply the footer style to any other tag on the page, and the text enclosed by that instance of that tag will take on the attributes of the footer class. 
For example, if you click anywhere in the text "Some paragraphs," click the <h2> in the tag selector, and then apply the footer style using the CSS Style palette, the text changes size to 9 points. The size specified in the footer style overrides the size specified in the H2 tag style. (Technically the font specified in footer overrides the font specified in H2 as well, but since both are the same there is no visible effect in the Document window. If you were to edit the footer style and change the font to Times New Roman, Times, serif, you would see that "Some paragraphs" appears in the font specified in footer .) The text is still green because there is no color attribute specified in footer . 

There are some cases when you want to apply a class style to a range of text inside a tag rather than to the entire text defined by that tag. For example, if a writer named Lori is working on a document with several colleagues, she can mark her changes by creating two styles called editsLori and removeLori . She might set the color attribute of both styles to red, and the decoration attribute of removeLori to strikethrough. When she adds words to the document, she can select the additions and apply the editsLori style; when she thinks some text should be removed, she can select it and apply the removeLori style. In each case, Dreamweaver inserts SPAN tags, with CLASS="editsLori" or CLASS="removeLori" attributes, around the selected text. 

If Lori's colleagues agree with the changes, they can place the insertion point anywhere in each edited area, click the <span> tag in the tag selector to select the entire edit, and either click (none) in the CSS Style palette to return the text to the default paragraph style, or press Delete to remove the selected text.
Creating a linked style sheet… 

The footer style you created may be fun to apply to other tags in basic.html to see the effects, but it isn't really useful anywhere else in the document. It would be very useful, however, if it were available in all the documents on your site. 

If you have already set up a style sheet for a document and then you decide that it would be more useful as an external style sheet that other documents can access, there's a simple procedure to convert the document's style sheet to a separate CSS file. 

To extract CSS style information from the current document and store it in an external CSS file: 

	1
	Choose Window > HTML Source to open the HTML Source inspector.

	2
	Scroll through the HEAD section of the document until you see <STYLE TYPE="text/css"> .

	3
	Click to place the insertion point to the left of the first style.

	
	The first style begins right after the opening comment tag ( <!-- ).

	4
	Drag down until you have highlighted everything up to, but not including, the closing comment tag ( --> ).

	5
	Press Control+X (Windows) or Command+X (Macintosh) to cut the selected text.

	6
	Choose File > New to open a new Dreamweaver document.

	7
	In the HTML Source inspector, select all of the text and tags in the new file by pressing Control+A (Windows) or Command+A (Macintosh).

	8
	Press Control+V (Windows) or Command+V (Macintosh) to paste the style information in place of the selected text.

	9
	Choose File > Save.

	
	In the dialog box that appears, give your file a name; the name should end with .css.

	10
	Close the CSS file.
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To link the original document to the external style sheet: 

	1
	Return to the original document (basic.html) and click in the HTML Source inspector.

	2
	Remove the following tags from the head of the document:

	
	<STYLE TYPE="text/css">

<!--

-->

</STYLE>

	3
	Close the HTML Source inspector.

	4
	In the CSS Style palette, click the Open Style Sheet button.

	5
	Click Link.

	6
	Browse to the CSS file that you just created. When you've selected the correct CSS file in the Link External Style Sheet dialog box, click OK.

	
	All the tag and selector styles in the CSS file are automatically applied to the appropriate tags in your document, and the class styles appear in the CSS Style palette.

	7
	Click Done.


