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Ms. Cress, Streamwood High School Photography
Building a Website using Macromedia Dreamweaver…

Step 1: Set Up Local Site
1. Select Dreamweaver Site under Create New from the Dreamweaver Start Window or 
Select Site > New Site…

2. In the Site Definition dialog box, switch to the advanced tab, and replace the assigned name with a more descriptive name. Click the folder icon to set the Local Root folder where you will store the files for your site on your computer.
3. Navigate to where you want to store the local root folder, select the folder or create a new folder, and click Select (PC) or Choose (MAC).

4. Click OK to close the Site Definition dialog box.

5. The local site is added to the Files panel. You are ready to start building your site.
Step 2: Create a Home Page
1. Choose File > New

2. In the New Document dialog box, select Blank Page and HTML from the Page Type column. Choose a layout from the Layout column. 

· Liquid = the layout automatically adjusts as a percentage to the width of the user’s Web browser window, but does not change based on the site visitor’s browser.
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Elastic = the layout adapts to the visitor’s browser text setting, and not based on the size of the browser.
· Fixed = Fixed pixel width
3. Make sure the Layout CSS drop-down menu is set to Create New File before you click Create.

4. Dreamweaver automatically offers to save the site’s style sheet in the root folder. Give it a name based on your site. Click Save. Dreamweaver adds it to the site’s list of files.
5. Click inside the page’s Title text window, and type in your own title for the page. This is not the file name, but the name your visitor will see at the top of the browser window or when they bookmark the page.
6. Select File > Save. In the Save As dialog box navigate to the site folder and save your files as index.html since this is your home page. Web servers know that the index.html page is the “front door” to your site. Dreamweaver adds it to the site’s list of files.
Step 3: Add Text

1. Adding text in Dreamweaver is not much different that using a word processing program

2. Select different headings and the paragraph option from the Format option on the properties panel. Paragraph are created with a hard return (Enter – PC, Return – MAC), breaks are created with a soft return (Shift + Enter – PC, Shift + Return – MAC).
3. Select a list (ordered or unordered) from the Properties panel where appropriate. Each list item is separated by a paragraph return.

4. Certain characters cannot be typed directly into a Web page. Choose Insert > HTML > Special Characters, i.e. Em-Dash.

5. Don’t change any other setting. Control the other settings with Cascading Style Sheets (CSS).

6. MACs display Web text about three-fourths the size that it appears on a PC.

7. Limit yourself to no more than two or three heading sizes per page.

Step 4: Insert Image Placeholder

Not always are your images/swfs ready when you are building your Web pages. You can add placeholder images and then add the images later.
1. Make sure your image place holder is inserted where you want it. Set you interface to split view.

2. If your cursor is sitting after the opening <h1> tag or other text formatting tag, fix the problem by repositioning your cursor just before the tag.
3. From the Menu bar, choose Insert > Image Objects > Image Placeholder. Type in a name for the image to come. If you know the dimensions of the final image, type it in. Dreamweaver inserts a block into the Web page, helping you gauge how the page will look.

Step 5: Add Images

After sizing and optimizing images in an external graphics program, you’re ready to add the Web-ready versions to you Web pages. Make sure you have your folder of images in the root folder of your site.
1. Place your cursor where you would like to add your image.
2. Choose image from the Common tab of the Insert toolbar.

3. Navigate to the image in the Select Image Source dialog box, and click Choose.

4. Type a brief description of the image in the Alternate text box and click OK.
Step 6: Add a Flash Video
1. Choose Flash Video from the Plug-in button drop-down menu on the Common tab of the Insert toolbar.
2. Use the dialog box to navigate to the Flash video you want to use, and click Choose. Click Yes when asked if you want to save the video in your site’s root folder.

3. Leave Video type set to Progressive Download Video and use the pop-up menu to choose a Skin style for the control buttons that appear with the video. Click the Detect Size button once to see the video’s natural width and height. Click OK when you’re done.
4. Dreamweaver inserts a placeholder on the page. Click the preview button to view the results in various browsers.

Step 7: Add a QuickTime Video

The process of adding a Quick Time video, or any video or audio file, is similar to the steps for Flash.

Step 8: Modifying Images in Dreamweaver
Crop

1. Before you crop an image, right-click (PC)/Ctrl +Click (MAC) the image in the Files panel and select Edit > Duplicate.

2. Reselect the original image in the Web page and click the Crop button in the Property Inspector.

3. Click and drag the black handles along the selection edge to set your crop lines. Double-click inside the selection and the image is trimmed.

Adjust Brightness

1. Select the image you want to adjust. You do not need to duplicate the image.
2. Click the Contrast/Brightness button in the Property Inspector.

3. To change the brightness or contrast drag the sliders or enter new values. Click OK to apply your adjustments.

Create Thumbnail Image
1. Before you crop an image, right-click (PC)/Ctrl +Click (MAC) the image in the Files panel and select Edit > Duplicate.

2. Select the image, press SHIFT as you drag one of the image’s corner handles. This reduces the image while maintaining its proportions. Watch the pixel dimensions in the Property Inspector. The new dimensions appear bold – even though the actual size of the file remains the same.
3. Click the Resample button on the Property Inspector to reduce the actual file size resulting in a smaller K size.

4. Click the Sharpen button on the Property Inspector to add crispness. 
5. Rename the smaller image in the Files panel by right-clicking (PC) or CTRL + Click (MAC) and choose Edit > Rename. Type the new name while preserving the .jpg suffix. Press Enter (PC) or Return (MAC) Click Update when Dreamweaver asks to update links to renamed image.
Replace Placeholder

1. Select the placeholder you wish to replace with the accurate image.

2. Click the Point-to-File button in the Property Inspector, drag the line to the image which will replace the placeholder, and release the mouse button. The new image replaces the placeholder.

Step 9: Add Tables

1. Open the page in which you want to add a table.

2. Click the Table button on the Common Insert tab.

3. When the Table dialog box appears, use the text boxes to set the number or Rows, Columns, the Table width, Border thickness, Cell padding, Cell spacing and whether you want to include a Header. Click OK to inset the new table.
4. When the new table appears, type your labels into the cells, pressing Tab to move from cell to cell.

5. If you need more cells as you type, switch the Insert toolbar to the Layout tab.

6. Click in the table row or column next to where you want to add the cells, and choose from the appropriate four buttons.

Note: Table cells can hold images as well as text.

Step 10: Change Table Parts

1. Ordinarily you select a row by moving your cursor to the table’s left side whereupon it become a bold arrow. However, this can sometime be difficult. It is easier to use the Tag Selector in the status bar. Click in any cell and the cell’s tag <td> is highlighted in the status bar.

2. Just to the left of the cell’s tag is the row’s tag <tr>. Click it and the entire row is selected.
3. Press Backspace (PC) or Delete (MAC) and the selected row is removed.

4. If you want to merge several cells into one, drag the cursor across the multiple cells. Right-click (PC) or Ctrl-click (MAC), choose Table > Merge Cells, or in the Property Inspector click the Merge Cells button.
5. After merging cells, you may need to change the content’s alignment. With the cells selected, click the Property Inspector’s Vert pop-up menu or Horz pop-up menu, choose a new setting.

6. To split a single cell into multiple cells, Right-click (PC) or Ctrl-click (MAC), choose Table > Split Cell, or in the Property Inspector click the Split Cell button.

Step 11: Importing Tabular Data

1. Open the page into which you want to place tabular data from another program, i.e. Excel.
2. Click in the page where you want to place the data.

3. In the Data tab of the Insert toolbar, click the first button to import your tabular data.

4. Click browse to navigate to where you’ve stored the document.

5. For the Delimiter, use Tab (or whatever format you used when saving the document.) In the Table section, choose Set to and use the adjacent text window to specify the width.
6. The data appears on the web page arranged in its own table. Clean-up is often needed.

Step 12: Sort Tables

1. Use the status bar’s tag select to click the <table> tag, then choose Commands > Sort Table to open the Sort Table dialog box.

2. Use the Sort by drop-down menu to choose which column controls the sort, then use the Order by drop-down menu to set whether the sort is done Alphabetically (or Numerically) and whether it’s in Ascending (or Descending) order.

3. Dreamweaver sorts the table based on your choices.

Step 13: Create Links
Links fall into two categories: internal links – links which connect different items within your own Web site, and external links – links which connect items out on the larger Web.

1. Select text you want to link to another page on you Web site. 

2. Make sure the Files panel and Property Inspector are both visible. Click the Point-to-File button and drag the line that appears to your target file in the Files panel. Release your cursor and the file path to the file appears in the Link text window.

3. Select the text you want to link to a page out on the Web.

4. Type the full Web address for the outside page, including http://, directly into the Link text window. 

5. Select _blank from the Target drop-down menu.

Step 14: Add Email Link

1. Select the text on your page that you want to link to email.

2. Click the Email Link button under the Common tab of the Insert Toolbar.

3. The selected text appears in the top field in the Email Link dialog box. Type the email address into the bottom field and click OK.
Step 15: Add Anchor Link

Anchor links enable Web visitors to jump to a specific spot within a ling Web page, sparing readers from scrolling through it. You must first create an anchor to mark the particular spot in the target document. Then you create the link to the spot.

1. Click on a particular spot – not the selecting the text itself – where you want to add an anchor link.

2. Click on the Named Anchor button in the Insert toolbar.

3. Type a distinctive name in the Named Anchor dialog box and click OK.

4. An anchor is added to the selected text.

5. Select the text you want linked to the anchor.

6. In the Property Inspector’s Link text window, type # and (with no space between) the exact anchor name you created earlier. Press Enter (PC) or Return (MAC) to activate the link.

Step 16: Image Links

Create internal and external links with images works exactly as it does for text links.

Step 17: Create Image Map
Image maps take the basic idea behind image links and give it extra power by making it possible to link separate hot spots within the image to multiple files.
1. With the Property Inspector visible, select the image for which you want to create an image map. Type a name for the image map in the Map text window.

2. Based on the shape of the hot spot you’ll be creating, click one of the three shape buttons.

3. Click in your image where you want the hotspot to begin, drag the cursor in a continuous motion, and release.

4. Click Ok in the warning dialog box.

5. In the Hotspot Inspector enter an Alt name for the spot.

6. Use the Point-to-File button to link the hot spot to a document.

7. If you need to adjust the hot spot’s boundary, click any of the square-shaped handles and drag it to a new spot.

Step 18: Setting Site Links Colors

By default, unvisited Web links are blue and underlined while visited links are purple and underlined.

1. Make sure your CSS Styles tab is visible and click the New CSS Rule button.

2. In the New CSS Rule dialog box, select Advance as the Selector Type and use the Define in drop-down menu to choose your main external styles sheet. Choose new if you currently do not have a main style sheet.
3. By default the Selector window’s content is highlighted. Press Backspace (PC) or Delete (MAC) to clear it, then use the drop-down menu to choose a: link. Click OK to close the dialog box.

4. In the Type category, which is automatically selected, click the Color box and use the drop-down menu to choose a color for your hyperlinks.

5. Change the Decoration checkbox from underline to none.

6. Position the dialog box so you can see your page, click Apply, and the page links loose the underline and the default color. 

7. Click OK to close the dialog box.

8. Repeat the 1 – 7 to create and define rules for the remaining three link states a:visited, a:hover, and a:active.
Step 19: Use Style Sheets

Tag-based styles, also known as element-based styles, apply to a specific HTML element, such as <h1> or <li> tag.  ID-based styles, also known as context-based styles, apply to a specific context, such as a page’s header or sidebar.  Class-based styles are not applied to a particular tag and, so, can be applied to multiple items anywhere in a page.

Dreamweaver puts everything you need for creating and managing style sheets in the CSS Styles tab. Along with the Files tab, you will want to have the CSS Styles tab always visible.

When there is no style sheet attached to a page, the page loses most of its formatting. The page has a simple top-to-bottom stacking of elements. This is called the page’s natural flow since there is no style sheet to float items to the left or right.

1. Click the chain-link Attach button in the CSS Styles tab.

2. Click Browse to navigate to where the desired style sheet resides. Leave Link selected and click OK. The page changes to reflect the styles sheet’s formatting.

3. To delete a style sheet, select it in the CSS Styles tab and click the Delete button at the bottom (the Trash can.) The style sheet is no longer listed in the CSS Styles tab.

Step 20: Create Tag-based Style

Tag-based styles affect every instance of the selected HTML element.

1. Click the Add CSS Rule button at the bottom of the CSS Styles tab.

2. In the New CSS Rule dialog box, select Tag as the Selector Type.

3. Choose a Tag, for example li (for list), in the Tag pop-up menu and it replaces the contents of the Tag text window. By default, Define in displays the page’s external style sheet if there is one. Click OK to close the dialog box.

4. In the Type category, set the Size and Color. Click Apply to see the effect of the change. Adjust if necessary, and click OK to close the dialog box.

Step 21: Create ID-based Style
You’re not limited to applying tag-based styles to every instance of an HTML element. You also can define such styles so that they’re applied only when the particular element appears in a specific part, or division (ID), of a page. These styles are powerful when used with Dreamweaver’s redesigned layouts, which use div tags to mark the page’s different divisions.

1. Select the heading in a division (ID) of your page, for example the Heading in a sidebar.

2. Click the Add CSS Rule button at the bottom of the CSS Styles tab.

3. Dreamweaver automatically identifies the Heading context, for example #container #sidebar h4. The Advanced Selector Type is also selected. All you have to do is click OK.

4. In the CSS Rule Definition dialog box that appears, use the left-side categories to precisely define how the selected element should look in this particular context (ID).

5. Click Apply to see the effect of the change. Adjust if necessary, and click OK to close the dialog box.

6. The new context-based rule is added to the style sheet in the CSS Styles tab.

7. You can also create a CSS Rule for a division (ID) of your page, for example the header.

8. Click the Add CSS Rule button at the bottom of the CSS Styles tab.

9. Dreamweaver automatically identifies the division (ID), for example #container #header.  All you have to do is click OK.

10. In the Background category, click the background color drop-down menu and use the eye dropper that appears to select a color.

11. In the Box category, change the padding values.

12. Click OK to close the rule definition dialog box.

Step 22: Create Class-based Style.

Class-based styles can be applied to multiple items on a page.

1. In the CSS Styles tab, click the add CSS Rule button at the bottom of the tab.

2. In the New CSS Rule dialog box, select Class as the Selector Type. In the Name text window type a name, for example pullquote, and click IK to close the dialog box.

3. Use the various categories in the rule definition dialog box to define the look of your class (pull quote.)

4. Click Apply to see the effect of your changes. Adjust if necessary, and click OK to close the dialog box. The new rule appears in the CSS Styles tab with the properties you assigned.

5. To apply the new class-based rule, select the text you want formatted as a pull quote. Right-click (PC) or Ctrl-click (MAC) the text, and choose CSS Styles >pullquote in the context menu.

Step 23: Create a Form

Forms enable you to collect information from your visitors using simple text areas and buttons. Before starting, check with the administrator of you internet Service Provider or Web site to find out what System CGI to use.
1. Switch the Insert toolbar to the Forms tab. Click the Form button. A blank form with a red dashed border appears on the page.
2. In the Property Inspector replace the generic name assigned to the form with something that indicates its purpose.
3. Type into the Action window the System CGI recommended for your Web server.

4. Click in the form where you want your first field to appear and click the Text field button ion the Forms tab.

5. The Input Accessibility Attributes dialog box appears each time you use the Text Field button. Type in an ID that helps you recognize this field’s purpose, for example firstname. Don’t use blank spaces or special characters. Select No label tag for a cleaner look. Click OK to close the dialog box.
6. The new filed is blank when it first appears in the form. In the Property Inspector, use the Char width and Init val text windows to adjust the field’s width and create an initial value that appears as a default label inside the field.

7. Repeat 1-6 for each text field you want added to the form.

8. To create a large text area for comments, click the Text Area button in the Forms tab. Create an ID when the Input Accessibility Attributes dialog box appears, and click OK.

9. When the larger field appears in your form, use the Property Inspector to set tits width and initial value.

10. To create a multiple-choice question, type the question below the previous text area. Press Shift + Enter (PC) or Shift + Return (MAC) to start a new line and click the Checkbox button in the Forms tab.

11. Create an ID in the Input Accessibility Attributes dialog box. In this case, create a label and select the After form item position. Click OK.

12. When the checkbox and label appears, check the Property Inspector to make sure that its Initial state is set to Unchecked. Repeat for all choices for the question.
13. To create a single-choice question, type the question below the previous text area. Press Shift + Enter (PC) or Shift + Return (MAC) to start a new line and click the Radio Group button in the Forms tab.

14. Give the Radio Group a distinctive name and rename each button using the label column. If you need more items, click the + button. Click OK when you’re done.

15. Use the Property Inspector if you want to set any button to be selected in their initial state.
16. To give the users a way to send their responses, click the Button button in the Forms tab.

17. Create an ID when the Input Tag Accessibility Attributes dialog box appears, and click OK.
18. The new button is name Submit when it first appears in the form. Use the Value window to create a more helpful label. By default , the action is set to Submit form.
19. Repeat 16 – 18 to give the users a second button to start over with the form. Again use the Property Inspector window to relabel the button. Be sure to change the Action to Reset form.

Step 24: Add Search Terms
It’s easy for you to help Web search engines highlight your site if you enter a succinct description, along with multiple keywords, in the home page. Dreamweaver places this information in the page’s hidden head code.

1. Open your home page and switch the Insert toolbar to the Common tab. Click the button that looks like a luggage tag and choose Keywords from its drop-down menu.

2. When the Keywords dialog box appears, type words that you think people might use to search for your site. Once you’re done, click OK.

3. In the Common tab, click the same button which now looks like a key, reflecting your last choice, and choose Description from the drop-down menu.

4. When the Description dialog box appears, type in a short paragraph that sums up the purpose of your Web site. Once you’re done, click OK.

Step 25 Check and Fix Links.

1. Choose Site > Check Links Site-wide. The Link Checker tab in the Results panel lists any pages with broken links.
2. Double-click any file listed and Dreamweaver open the Property Inspector, along with the page that contains the broken link.

3. Use the Property Inspector’s Link text field to correct the mistake by typing in the correct link or redrawing the link with the Point-to-File button.

4. Once you make the fix, save the page and the Results panel automatically removes the broken link from its list.

5. Repeat until you’ve fixed all broken links.

Step 26: Publish Site

Normally the Files panel only shows your local files. Click the Expand/Collapse button to see them along with your remote Web site’s files.

Set Up Remote Site
1. In the Remote Site panel, click the define a remote site link.

2. The Advanced view appears in the Site Definition dialog box with the Remote Info category automatically selected. Choose FTP in the Access drop-down menu.

3. Fill in the FTP address for your new site, base on information provided by the firm hosting your site.

4. You don’t have to specify which folder will contain the site, but it can help keep your site better organized

5. Fill in your login and password, again based on the information from your Web host.

6. Select Use passive FTP unless your Web host firm specifically telss you not to do so.
7. Assuming you are already online, click Test and it will take a moment for Dreamweaver to determine if the connection is working.

8. If the test connection works, click OK. Close the Site Definition dialog box by click OK.

Connect to Remote Site

1. With your internet connection connected, make sure the Files panel is visible, and click the Expand/Collapse button.

2. Once the view expands, click the Connect button.

3. The status dialog box appears briefly as Dreamweaver negotiates the connection to you Web site.

4. Once the connection is made, the remote’s files appear on the left side of the Files panel.

5. You’re ready to upload your files.

Upload Multiple Files

1. In the Local Files pane, click to select the top-level folder that contains all files you want to upload. Note you can also select individual files or folders by Ctrl-clicking (PC) or Cmd+clicking (MAC) them in the Local Files pane.

2. Drag the selected local files to the folder in the Remote Site or click the Put button to upload them. A series of progress dialog boxes flash by as Dreamweaver uploads the home page and all its dependent files. This may take several minutes to complete, depending on how many files you are uploading and the speed of you connection.

3. When the progress dialog boxes stop appearing, press  the Refresh button. Compare the names of the Remote Site files to the names of your Local Files.
4. Once you’re done, click the Disconnect button.

Upload a Single Page

Sometime you’ll need to upload only a single page – for example, when you need to update information for fix a mistake.

1. Once you’re connected, click the page file in the Local Files pane and drag it to the folder where the older version appears in the Remote Site pane.

2. A single progress dialog box appears as Dreamweaver uploads the selected page. Use your Web browser to check the page on the remote Web site, and when you’re done, click the Disconnect button.

